WATCH TALK FORUMS banner
1 - 9 of 9 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter · #1 ·
My Invicta 0420 is running 15 - 20 secs fast a day. I don't wear her that often so she doesn't get banged around.
I don't know what happened!!!!!!
 

·
Super Moderator
Joined
·
16,571 Posts
Sorry about that! Are you storing it in a different position when you take it off at night?
 

·
Super Moderator
Joined
·
16,571 Posts
After thinking it over, I'll bet your problem is simply: you're not wearing it often enough for it to have any consistency. I have the same problem with my vintage Hammys. Wear it for a week or so, or at least keep it wound-up if you wear other pieces. Then give it an accuracy check and see how it's running.
My regular Pro Diver


was the same way. The accuracy was bad enough I almost threw it in my sock drawer. But the more I wore it, the more it settled in. Now it's probably good for +6 to 10 seconds. I can happily live with that.
 

·
Super Moderator
Joined
·
16,571 Posts
Oh well! I've exhausted my little bag of tricks. I'll shut up now and let some others try and help. Of course, there's always The Technical Forum......:wink:
Good luck!
 

·
Registered
Joined
·
177 Posts
Discussion Starter · #9 ·
CometHunter, you were right,she wasn't getting enough wrist time.
I put the her on at 2030 hrs on the 10th and wore her all night,all day of the 11th and all last night. Checked her this morning at 0800 against the USNO clock and she is only running 2 secs fast. I'm going to check tomorrow morning after wearing her all day today and tonight.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top