WATCH TALK FORUMS banner
1 - 5 of 5 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
So I bought am awesome Astronaut yesterday. It was running great and keeping great time. So of course I like to see the condition of my Accutrons movements. I opened it up and the gasket stuck, and stretched a bit. I got it put back in the best I could. Slapped it all back together, and now I have a NON WORKING watch! Its still humming, but no hands move. Im stunned. I found at least one thread that stated the gasket could be my issue. Im having a hard time believing this though. Anyone have any thoughts?



Thanks

Justin
 

·
Registered
Joined
·
3,869 Posts
You might try the Bulova and Accutron Forum, especially a guy who calls himself Akkatron.
I don't work on my Accutrons, the tiny parts drive me crazy, but I can tell you that the same thing has happened to me twice and both times I fixed it by taking the back off again and replacing it being very careful to put it straight on and not at any angle. Apparently the adjusting rod can get the gears into a bind if it isn't put on straight.
 

·
Registered
Joined
·
617 Posts
You know how when you flip that tab over to set it? That pulls the crown out a little and engages the setting mechanism. It really can't run with the setting mechanism engaged.

When you stuffed the gasket back in, you didn't get it flat and it is holding the case back too far out. This is the same as pulling the stem out and it won't run. Try to seat the gasket properly.

Steve
 

·
Registered
Joined
·
2,892 Posts
So I bought am awesome Astronaut yesterday. It was running great and keeping great time. So of course I like to see the condition of my Accutrons movements. I opened it up and the gasket stuck, and stretched a bit. I got it put back in the best I could. Slapped it all back together, and now I have a NON WORKING watch! Its still humming, but no hands move. Im stunned. I found at least one thread that stated the gasket could be my issue. Im having a hard time believing this though. Anyone have any thoughts?
Thanks
Justin
Not unheard of. I bought a 214 Spaceview that had a new style case back gasket. When I found an O.E. type and installed it, the stem would't move down far enough to engage. Sometimes the hack spring needs a little adjustment, too.
 
1 - 5 of 5 Posts
Top